PHP Compatibility Checker

PHP Compatibility Checkerは、WPテーマやWPプラグインのPHPバージョンの互換性を確認できるWordPressプラグインです。

PHPのプログラミングが分からない素人でも、現在利用しているWPテーマやWPプラグインがどのPHPバージョンに対応しているか(互換性)を確認できます。

最近は「PHP7」に対応したレンタルサーバーが増えてきました。「PHP7」はPHP5に比べ2倍以上の実行速度を実現しています。自分が契約しているレンタルサーバーのPHPバージョンを「PHP7」に切り替えた際に問題が発生しないかを事前に確認しておきましょう。

このWPプラグインを利用すれば、現在利用中のWPテーマやWPプラグインが「PHP7」に対応しているかどうかを簡単に確認できます。便利なWPプラグインなので活用しましょう。

はじめに

このプラグインが優れている点

  1. WPテーマやWPプラグインのPHPバージョンの互換性を簡単に確認できる。
  2. PHPのプログラミングが分からなくても利用できます。PHPのバージョンとスキャン対象を選択してスキャンを実行するだけです。

使用上の注意点

このWPプラグインはPHPの互換性を機械的にチェックします。スキャン対象のPHPを実行している訳ではありません。PHP実行時に発生する問題は検出できません。

インストール方法

管理画面から検索してインストールして下さい。もしくは、WordPress.org からダウンロードし、アップロードしてインストールして下さい。

  1. WordPress管理画面 > プラグイン > 新規追加 >「PHP Compatibility Checker」で検索
  2. WordPress.org からダウンロード

プラグインの使い方

管理画面の場所

このプラグインの管理画面は下記の場所にあります。

WordPress管理画面 > ツール > PHP Compatibility

PHP Compatibility Checker

WPプラグインの使い方は簡単です。
PHPのバージョンを選択して、「Scan site」ボタンをクリックしてスキャンを実行します。

PHP Compatibility Checker

スキャン完了画面

スキャンが完了して、緑色で「Compatible」と表示されれば、選択したPHPバージョンに互換性があります。

PHP Compatibility Checker

補足説明

サーバー環境によっては「BackWPup」や「JetPack」のWPプラグインで警告やエラーのメッセージが表示される場合があります。

このWPプラグインはPHPの互換性を機械的にスキャンしています。WPプラグインによっては正しい結果を検出できない場合があります。ちなみに「エックスサーバー」の環境では「PHP7」でも問題なく運用できるのを確認しています。

まとめ

PHP Compatibility Checkerは、利用中のWPテーマやWPプラグインのPHPバージョンの互換性を確認できるWordPressプラグインです。

最近は「PHP7」に対応したレンタルサーバーが増えてきました。「PHP7」はPHP5に比べ2倍以上の実行速度を実現しています。自分が契約するレンタルサーバーのPHPバージョンを「PHP7」に切り替える場合は、このWPプラグインを利用して、PHPバージョンを切り替えた際に問題が起こらないのか事前に確認しましょう。

PHPのプログラミングが分からなくても利用できます。便利なWPプラグインなので活用しましょう。

スポンサーリンク